$re = '/\d{2,3}/';
$str = '00
123
001
s002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);