$re = '/\b(?<label>[a-z0-9_]\w*)\s?(?<selector>=~?|![=~])\s?"?(?<value>(?<=")(?:[^\\\\"]|\\\\.)*(?=")|\w+[^\s},]+)/mi';
$str = '{quote =~ "She said: \\"Hi, all!( How\'re you…)?\\"", quote=~some_value}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);