# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\d{1,3}(?:\n(?!\s*\d{1,3}\n).*){4}"
test_str = (" تحميل ملف الطباعة تعليمات طباعـــة\n"
" 1 / 4 \n"
" \n"
"Main Report\n"
" \n"
" 25%\n"
" 50%\n"
" 75%\n"
" 100%\n"
" 125%\n"
" 150%\n"
" 200%\n"
" 300%\n"
" 400%\n"
" تقرير بيانات الطلاب الذين سددوا المصروفات الدراسية\n"
" عن طريق منافذ الدفع البنكي 2019-2020 \n"
"المديرية \n"
"المرحلة\n"
":\n"
":\n"
"الإدارة \n"
"التبعية\n"
":\n"
":\n"
"كود الطالب\n"
"جهة الدفع\n"
"رقم قومي الطالب\n"
"اسم الطالب\n"
"اعدادى\n"
"رسمى\n"
"اسم المدرسة\n"
":\n"
"م\n"
"مطروح\n"
"الحمام\n"
"اولاد مسعود الاعدادية المشتركة\n"
"الصف\n"
":\n"
"الصف الأول\n"
" 1\n"
" 458316219 \n"
" 30709101600371 \n"
"ابراهيم وليد ابراهيم ابوالحمد\n"
"منافذ فورى\n"
" 2\n"
" 458361688 \n"
" 30702263300318 \n"
"احمد ابوالريش فرج عبدالله\n"
"منافذ فورى\n"
" 3\n"
" 458312720 \n"
" 30703143300418 \n"
"اسلام فتحى محمد ناجى\n"
"منافذ فورى\n"
" 4\n"
" 458790904 \n"
" 30606101802299 \n"
"اسلام نصار حسين نصار حسين عبد الونيس\n"
"منافذ فورى\n"
" 5\n"
" 458312908 \n"
" 30612013300259 \n"
"ايمن راضى صالح سلومه\n"
"منافذ فورى\n"
" 6\n"
" 458884564 \n"
" 30802203300186 \n"
"بسمه محمد ابراهيم ظدم\n"
"منافذ فورى\n"
" 7\n"
" 477625786 \n"
" 30708263300235 \n"
"بشار نصر الله مصوف السايب\n"
"منافذ فورى\n"
" 8\n"
" 458805339 \n"
" 30708203300708 \n"
"بشرى محمد عبدالناصر عبدالرؤوف رحمى\n"
"منافذ فورى\n"
" 9\n"
" 458707736 \n"
" 30711103300663 \n"
"جنات منصور مسعود ابوسيف\n"
"منافذ فورى\n"
" 10\n"
" 458884629 \n"
" 30801013303115 \n"
"حكيم عبدالقادر فرج قنديل\n"
"منافذ فورى\n"
" 11\n"
" 464285926 \n"
" 30801121603028 \n"
"روان ابراهيم محمد محمد قطب\n"
"منافذ فورى\n"
" 12\n"
" 459700550 \n"
" 30707150204055 \n"
"سعيد نوح قوية نصر\n"
"منافذ فورى\n"
" 13\n"
" 458804725 \n"
" 30702253300379 \n"
"عبدالرحمن ابراهيم عبدالرؤوف رحمى\n"
"منافذ فورى\n"
" 14\n"
" 457185700 \n"
" 30702013300096 \n"
"عبدالله حسين رضوان يونس\n"
"منافذ فورى\n"
" 15\n"
" 458707614 \n"
" 30803083300515 \n"
"عبدالناصر خميس محمد عقيل\n"
"منافذ فورى\n"
" 16\n"
" 458312757 \n"
" 30707113300427 \n"
"عبير على عبدالرؤف رحمى\n"
"منافذ فورى\n"
" 17\n"
" 458361421 \n"
" 30711153300478 \n"
"على حامد راغب زايد\n"
"منافذ فورى\n"
" 18\n"
" 446292331 \n"
" 30605243300073 \n"
"فارس عطيه عباس بسيس\n"
"منافذ فورى\n"
" 19\n"
" 463507046 \n"
" 30608183300574 \n"
"فارس فرج شحات قنديل\n"
"منافذ فورى\n"
" 20\n"
" 458810352 \n"
" 30701283300059 \n"
"كريم جبريل سليمان غالب\n"
"منافذ فورى\n"
" 21\n"
" 467915100 \n"
" 30709161801074 \n"
"كريم عاطف عبدالباسط حجازى\n"
"منافذ فورى\n"
" 22\n"
" 458361712 \n"
" 30702263302396 \n"
"محمد ابوالريش فرج عبدالله\n"
"منافذ فورى\n"
"2020/06/12\n"
"Page 1 of 4\n"
"مسئول شئون الطلاب\n"
"خاتم \n"
"الشعار\n"
"مدير المدرسة\n"
" 2015© جميع الحقوق محفوظة لمركز معلومات -وزارة التربية والتعليم")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.