$re = '/(?:^|[^\d])[0]*(?<serial>1234)(?:[^\d]|$)/m';
$str = 'test1234
1234test
test1234test
test12345test
test01234test
test51234test
test012345test
12345
01234
41234
Replace 1234 with desired number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);