re = /([a-zA-Zא-ת])\1{4,}/m
str = 'bbbbbbbbb awejalkdjlj weeeeeeee ewrחלילדחגיכלחיחחחחח'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end