using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=:):(.*)";
string substitution = @" ";
string input = @"2017 - Alpha Romeo United kingdom : New vehicle (by abc)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}