$re = '/([0-9]{1,2}h)\s*([0-9]{1,2}min)*:\s*([\w\W]*?)(?=^[0-9]{1,2}h\s*([0-9]{1,2}min)|\Z)/m';
$str = '1h 30min: Title
- Description Line 1
1h 31min: Title
- Description Line 1h 31min 1
- Description Line 2
- Description Line 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);