package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`The`)
var str = `The fat cat sat on the mat.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}