using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(data-key[^,\n]*,).*(?![\s\S]*?\nBAR)";
string input = @"data-key=foo1,
data-key=foo2,
data-key=foo3,
BAR,
data-key=foo4,
asd
data-key=foo5,
asfda
data-key=foo6, foo bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}