use strict;
my $str = '12/22/2001';
my $regex = qr/(?<month>\d{1,2})\/(?<day>\d{1,2})\/(?<year>\d{4})/mp;
my $subst = '${year}-${month}-${day}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";