$re = '/\s+\./m';
$str = 'My friend is hungry .I am happy';
$subst = ". ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;