package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[1-9]\d*|\d+\.\d*[1-9])$`)
var str = `VALID
_______
40000
45
4
45.67
67.8
60.
61.0
1.00
01.00
02.00
03.0
89.50
50.00
0.10
NOT VALID
_______
0.00
00000
0.0
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}