$re = '/\s+\S*$/m';
$str = 'Buddy you\'re a boy make a big noise Playin in the stre';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);