re = /(?<=[()\/*+-])(?=[0-9()])|(?<=[0-9()])(?=[()\/*+-])/m
str = '1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end