using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/)[^\/]+csproj";
string input = @"Videos/common/Project/Project01/video.project_01.StatusOK/test/video.project_01.StatusOK.csproj
Videos/common/Project/Project01/video.project_01.StatusOK/video.project_01.StatusOK.csproj";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}