const regex = /\bGrand Total\s+(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bGrand Total\\s+(.*)', 'gm')
const str = ` Credit Note InterGlobe Aviation Limited
(Original For Recipient)
Jorhat Airport
Airport Road
Raraiyah
Jorhat
Assam
785006
GSTIN : 18AABCI2726B1Z1
Number : AS2181901AB01561
Date : 23-Jan-2019
Passenger Name :
PNR : KFRFUZ Flight No : 6E - 5988 From : JRH To : CCU Place of Supply : Haryana
GSTIN of Customer : 06AAACM0829Q1Z8
GSTIN Customer Name : MARUTI SUZUKI INDIA LIMITED
Currency : INR
NonTaxable IGST CGST SGST/UGST
Taxable Total(Incl
Description SAC Code /Exempted Total
Value
Tax % Amount Tax % Amount Tax % Amount
Taxes)
Value
Airport Charges 0.00 3,837.00 3,837.00
0.00 0.00 0.00 0.00 0.00 0.00
3,837.00
Grand Total
0.00 3,837.00 3,837.00 0.00 0.00 0.00 3,837.00
Original Invoice Number: AS1181901AI71392 Date: 15-Jan-2019
1. Air Travel and related Charges :- Includes all Charges related to air transportation of passengers
2. Airport Charges :- Includes ADF,UDF,PSF and other airport charges collected on behalf of Airport Operator,as applicable
3. Misc. Services :- Includes Charges of Lounge,Medical Assistance and Travel Certificate
4. Meal :- Includes all prepaid meals purchased before travel
5. Good Karma :- Includes contributions made towards IndiGo's Good Karma initiative and Clear the Air initiative
made at the time of reservation
6. Amounts have been rounded off.
InterGlobe Aviation Limited
Registered Office: Central Wing, Ground Floor, Thapar House, 124 Janpath, New Delhi -110001,India.
F 011-43513200. Email: corporate@goindigo.in
Corporate Office: Level 1, Tower C, Global Business park, MG Road, Gurgaon-122002, Haryana,India.
T +91 124 435 2500. F +91 124 406 8536 goindigo.in
CIN no. L62100DL2004PLC129768 , PAN no. AABCI2726B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}