re = /(?<=(?:from|to)\s*)(?:(?:0[1-9]|[12][0-9]|3[01])-(?:0[1-9]|1[1,2])-(?:19|20)\d{2})/m
str = 'from 10-08-2024 to 12-08-2024'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end