re = /\[{data}\(.*?\)\]/
str = '{[{main}(other data)][{data}(other data)][{address}(other data)]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end