re = /^(?=.*Coffee)[^\d7]*7\D*$/m
str = 'text... Coffee 7 ... more...
text... Coffee 8 ... more...
text... Coffee ... more...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end