re = /^[a-zA-Z]{2}(?:0[2-9]|[1-8][0-9]|9[0-8])[a-zA-Z0-9]{4}[0-9]{6}[a-zA-Z0-9]{0,20}$/m
str = 'ab981aB4123456
DO NOT MATCH
ab991aB4123456
ab011aB4123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end