# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((ServiceCodeID\s*=\s*[^\s@a-z][0-9]{1,})|(ServiceCodeID\s*in\s*\(\s*[0-9\,*]{1,}\s*\)))|((ProgramID\s*=\s*[^\s@a-z][0-9]{1,})|(ProgramID\s*in\s*\(\s*[0-9\,*]{1,}\s*\)))"
test_str = ("1000000128 - WhereClause=(@HousingReferral@ = 1 AND Service.FormID= 1000000139) OR @HousingReferral@ ='' OR (@HousingReferral@ = 1 AND ServiceReferral.ServiceCodeID = 360 AND Service.FormID IS NULL)&SqlExpression=ISNULL(Service.FormID,1127)\n"
"1000000234 - WhereClause=(@HousingReferral@ = 1 AND Service.FormID= 1000000139) OR @HousingReferral@ ='' OR (@HousingReferral@ = 1 AND ServiceReferral.ServiceCodeID = 360)&SqlExpression=ISNULL(Service.FormID,1127)\n"
"1000000235 - SqlExpression=ISNULL(Service.FormID,1127)&WhereClause=(@HousingReferral@ = 1 AND Service.FormID= 1000000139) OR @HousingReferral@ ='' OR (@HousingReferral@ = 1 AND ServiceReferral.ServiceCodeID = 360 AND Service.FormID IS NULL)\n"
"1000001453 - WhereClause= ((@HousingReferral@ = 1 AND Service.FormID IN( 1000000139,1E9+431)) OR @HousingReferral@ ='' OR (@HousingReferral@ = 1 AND ServiceReferral.ServiceCodeID IN (360,725,726,727,728,729,730) AND Service.FormID IS NULL) OR (ServiceCode.CoordinatedEntryEvent IS NOT NULL OR ServiceCode.CoordinatedEntryEvent IS NOT NULL ))&SqlExpression=ISNULL(Service.FormID,1127)\n"
"1000001482 - SearchOnly=1&WhereClause=ServiceCode.ServiceCodeID IN (738,739,742) AND CEEventResult.ReferralResult IS NULL\n"
"1000001488 - SearchOnly=1&WhereClause=CEAssessmentLink.PrioritizationStatus = 1 AND Enrollment_Open.ProgramID = 21003\n"
"1000001506 - NoSearch=1&Alignment=center&SqlExpression= (SELECT CASE WHEN ReferralServiceCode.ServiceCodeID = 749 THEN 728 WHEN ReferralServiceCode.ServiceCodeID IN (748,750) THEN 729 ELSE ISNULL(ReferralServiceCode.ServiceCodeID,ServiceCode.ServiceCodeID) END AS ServiceCode)\n"
"1000001567 - WhereClause=(@HousingReferral@ = 1 AND Service.FormID IN( 1000000139,1E9+431)) OR @HousingReferral@ ='' OR (@HousingReferral@ = 1 AND ServiceReferral.ServiceCodeID IN (360,725,726,727,728,729,730) AND Service.FormID IS NULL) &SqlExpression=ISNULL(Service.FormID,1127)\n"
"1000001579 - SearchOnly=1&WhereClause=CEAssessmentLink.PrioritizationStatus = 1 AND Enrollment_Open.ProgramID = 21003\n"
"1000001586 - SearchOnly=1&WhereClause=CEAssessmentLink.PrioritizationStatus = 1 AND Enrollment_Open.ProgramID = 21003")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.