import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?P<head>^tacacs[\\s|-]server\\shost\\s)(?P<ipv4>(\\d+\\.){3}\\d+)(?P<key>\\skey\\s[0-9]\\s\\S[a-zA-Z0-9]+\\S)?(?P<tail>(.*))";
final String string = "aaa group server tacacs+ tacacs\n"
+ " server 172.26.60.235\n"
+ " server 172.24.248.209\n"
+ " source-interface mgmt0\n"
+ "aaa group server tacacs+ TACACS-GROUP\n"
+ " server 172.26.60.235\n"
+ " source-interface mgmt0\n"
+ "aaa group server tacacs+ TACACS-TEST1\n"
+ " server 172.26.60.235\n"
+ " server 172.24.248.209\n"
+ "aaa group server tacacs+ tacacs+group\n"
+ " source-interface mgmt0\n\n\n"
+ "ip tacacs source-interface mgmt0\n\n"
+ "tacacs-server host 172.26.60.235 key 7 \"Foihmr3\" timeout 5\n"
+ "tacacs-server host 172.24.248.209 key 7 \"Foihmr3\"\n\n\n"
+ "tacacs server host 172.24.248.209 key 7 \"Foihmr3\"\n\n"
+ "tacacs-server host 172.26.60.235 timeout 5\n\n"
+ "tacacs-server host 172.26.60.235\n"
+ "tacacs-server host 172.24.248.209";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}