package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{3}\-?[0-9]{2}\-?[0-9]{4}\-?$`)
var str = `213-45-2344`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}