re = /^((https?|ftp)\:\/\/)?([a-z0-9]{1})((\.[a-z0-9-])|([a-z0-9-]))*\.([a-z]{2,6})(\/?)$/
str = 'ftp://www.main.ru'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end