import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9]{1,3}_)?[a-zA-Z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}";
final String string = "7_b4718152-d9ed-4724-b3fe-e8dc9f12458a7_b4718152-d9ed-4724-b3fe-e8dc9f12458a\n"
+ "7_b4718152-d9ed-4724-b3fe-e8dc9f12458a\n"
+ "b4718152-d9ed-4724-b3fe-e8dc9f12458a\n"
+ "_b4718152-d9ed-4724-b3fe-e8dc9f12458a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}