using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}.\d{3})(.*)(Message Picked from the queue....|Response Message : )([\S\s]+?>)\n(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}.\d{3})";
string input = @"2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17618 TX:0 - SesIdCode is null. So no audit log transaction for this transaction
2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.component.SenderComponent U:UNKNOWN SC:17618 TX:0 - SendMessage, Invockation End..
2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] DEBUG c.e.r.p.endpoint.PickerProcessor U:UNKNOWN SC:17618 TX:0 - Message Picked from the queue....<soapenv:Envelope xmlns:soapenv=""http://schemas.xmlsoap.org/soap/envelope/"">
<soapenv:Header />
<soapenv:Body>
<EAI_MESSAGE>
<EAI_HEADER>
<ServiceName>SMS</ServiceName>
<ServiceType>SendSms</ServiceType>
<ServiceVersion>1.0</ServiceVersion>
<Client>xx</Client>
<ClientChannel>SBA</ClientChannel>
<MsgChannel>WebServices</MsgChannel>
<SecurityInfo>
<Authentication>
<UserId>xxx</UserId>
<Password>xxx</Password>
</Authentication>
<Authorization>
<UserId>xxx</UserId>
</Authorization>
</SecurityInfo>
<SnapIns>
<NameValue Name="" Value="" />
</SnapIns>
<RequestorLanguage>E</RequestorLanguage>
<EaiReference>0</EaiReference>
<ReturnCode>0000</ReturnCode>
</EAI_HEADER>
<EAI_BODY>
<EAI_REQUEST>
<SendSmsRequest>
<RefID>502521</RefID>
<ISD>974</ISD>
<PhoneNO>xxx</PhoneNO>
<Message>Dear User, Your unique OTP pin for xxx is xxxx</Message>
<Language>E</Language>
<Priority>2</Priority>
<SchDate />
<SrcKey>xx</SrcKey>
<Department>xx xx</Department>
<SMSUser>SMS Alerter</SMSUser>
</SendSmsRequest>
</EAI_REQUEST>
</EAI_BODY>
</EAI_MESSAGE>
</soapenv:Body>
</soapenv:Envelope>
2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17618 TX:0 - Starting the processor -com.eix.processor.persistence.InPersisterProcessor
2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.p.InPersisterProcessor U:UNKNOWN SC:17618 TX:0 - In Persister Processor is invoking...
2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17618 TX:0 - SesIdCode is null. So no audit log transaction for this transaction
2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17600 TX:0 - in saveMessage
2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17600 TX:0 - Got eix ID from Instance ID 1
2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - No of Routes are--1
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.message.util.ConditionHelper U:UNKNOWN SC:17740 TX:0 - Start if verifyCondition for : null
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - conditionTestResult : true
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - In populateRecipient-- Start -->null
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyCopyRecipients Start
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyCopyRecipients End
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - In populateRecipient-- End
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyMessageRecipientsforManualRouting -- End
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - allRecipientinErrorOnNoRecipient : false
2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method updateParentAddrCommDtls Start
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - addrCommList.size() --->> 0
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - messageRecipients without Adrs Com ID() --->> MessageRecipient [messageType=null, messageVersion=null, messageStandard=null, envelopeType=null, splitterClassName=null, addressType=null, address=null]
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - ----Recipients are----
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient AddressComm ID--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address Type--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Participant ID--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Route Communication ID--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Route Communication Address Type--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Type--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Version--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Standard--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address Envelope Type--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Splitter Class--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Send Original Message--null
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - -------------------------------------
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyMessageRecipients -- End
2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.route.MessageRouteProcessor U:UNKNOWN SC:17740 TX:0 - MessageRouteProcessor process method -- End
2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17740 TX:0 - Starting the processor -com.eix.processor.system.WebServiceProcessor
2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.system.WebServiceProcessor U:UNKNOWN SC:17740 TX:0 - Service Processor is invoking...
2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Invoking webservice http://alteainterface.qatarairways.com.qa/AlteaODS/AlteaODS.svc
2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Response Message : <MESSAGE><HEADER><ServiceName>xxxx xxxx</ServiceName><ServiceType>PassengerInfo</ServiceType><ServiceVersion>1.0</ServiceVersion><Client>xxx</Client><ClientChannel>xx</ClientChannel><MsgChannel>WebServices</MsgChannel><SecurityInfo><Authentication><UserId>xx</UserId><Password>xxx</Password></Authentication></SecurityInfo></HEADER><BODY><RESPONSE><passengerStatus>Invalid</passengerStatus><RegisteredFlight></RegisteredFlight><passengerPhone></passengerPhone><passengerEmail></passengerEmail><FFPNumber></FFPNumber></RESPONSE></BODY></MESSAGE>
2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17740 TX:0 - Starting the processor -com.eix.processor.persistence.OutPersisterProcessor
2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.p.OutPersisterProcessor U:UNKNOWN SC:17740 TX:0 - Out Persister Processor is invoking...
2018-11-25 14:27:58.179 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17740 TX:0 - SesIdCode is null. So no audit log transaction for this transaction
2018-11-25 14:27:58.185 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17633 TX:0 - start updateINAndInsertOutMessageSync
2018-11-25 14:27:58.185 [ajp-bio-172.27.9.196-8009-exec-1] WARN c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Authentication is null
2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Got eix ID from Instance ID 1
2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - ****** Returning EIX ID-> 3
2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Got eix ID from Instance ID 1
2018-11-25 14:27:58.188 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - ****** Returning EIX ID-> 3
2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17633 TX:0 - SesIdCode is null. So no audit log transaction for this transaction
2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.component.SenderComponent U:UNKNOWN SC:17633 TX:0 - SendMessage, Invockation Start..
2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17633 TX:0 - SesIdCode is null. So no audit log transaction for this transaction
2018-11-25 14:27:58.202 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17618 TX:0 - in updateSendStatusInOutMessage
2018-11-25 14:27:58.202 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.d.r.i.OutMessageRepositoryImpl U:UNKNOWN SC:17618 TX:0 - in updateSendStatusInOutMessage
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}