import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}.\\d{3}.*(?:Message Picked from the queue....|Response Message : )([\\S\\s]+?>)\\n\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}.\\d{3}";
final String string = "2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17618 TX:0 - SesIdCode is null. So no audit log transaction for this transaction\n"
+ "2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.component.SenderComponent U:UNKNOWN SC:17618 TX:0 - SendMessage, Invockation End..\n"
+ "2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] DEBUG c.e.r.p.endpoint.PickerProcessor U:UNKNOWN SC:17618 TX:0 - Message Picked from the queue....<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">\n"
+ " <soapenv:Header />\n"
+ " <soapenv:Body>\n"
+ " <EAI_MESSAGE>\n"
+ " <EAI_HEADER>\n"
+ " <ServiceName>SMS</ServiceName>\n"
+ " <ServiceType>SendSms</ServiceType>\n"
+ " <ServiceVersion>1.0</ServiceVersion>\n"
+ " <Client>xx</Client>\n"
+ " <ClientChannel>SBA</ClientChannel>\n"
+ " <MsgChannel>WebServices</MsgChannel>\n"
+ " <SecurityInfo>\n"
+ " <Authentication>\n"
+ " <UserId>xxx</UserId>\n"
+ " <Password>xxx</Password>\n"
+ " </Authentication>\n"
+ " <Authorization>\n"
+ " <UserId>xxx</UserId>\n"
+ " </Authorization>\n"
+ " </SecurityInfo>\n"
+ " <SnapIns>\n"
+ " <NameValue Name=\"\" Value=\"\" />\n"
+ " </SnapIns>\n"
+ " <RequestorLanguage>E</RequestorLanguage>\n"
+ " <EaiReference>0</EaiReference>\n"
+ " <ReturnCode>0000</ReturnCode>\n"
+ " </EAI_HEADER>\n"
+ " <EAI_BODY>\n"
+ " <EAI_REQUEST>\n"
+ " <SendSmsRequest>\n"
+ " <RefID>502521</RefID>\n"
+ " <ISD>974</ISD>\n"
+ " <PhoneNO>xxx</PhoneNO>\n"
+ " <Message>Dear User, Your unique OTP pin for xxx is xxxx</Message>\n"
+ " <Language>E</Language>\n"
+ " <Priority>2</Priority>\n"
+ " <SchDate />\n"
+ " <SrcKey>xx</SrcKey>\n"
+ " <Department>xx xx</Department>\n"
+ " <SMSUser>SMS Alerter</SMSUser>\n"
+ " </SendSmsRequest>\n"
+ " </EAI_REQUEST>\n"
+ " </EAI_BODY>\n"
+ " </EAI_MESSAGE>\n"
+ " </soapenv:Body>\n"
+ "</soapenv:Envelope>\n"
+ "2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17618 TX:0 - Starting the processor -com.eix.processor.persistence.InPersisterProcessor\n"
+ "2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.p.InPersisterProcessor U:UNKNOWN SC:17618 TX:0 - In Persister Processor is invoking...\n"
+ "2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17618 TX:0 - SesIdCode is null. So no audit log transaction for this transaction\n"
+ "2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17600 TX:0 - in saveMessage\n"
+ "2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17600 TX:0 - Got eix ID from Instance ID 1\n"
+ "2018-11-25 14:10:38.673 [ajp-bio-172.27.9.196-8009-exec-1] INFO \n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - No of Routes are--1\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.message.util.ConditionHelper U:UNKNOWN SC:17740 TX:0 - Start if verifyCondition for : null\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - conditionTestResult : true\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - In populateRecipient-- Start -->null\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyCopyRecipients Start\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyCopyRecipients End\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - In populateRecipient-- End\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyMessageRecipientsforManualRouting -- End\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - allRecipientinErrorOnNoRecipient : false\n"
+ "2018-11-25 14:27:58.097 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method updateParentAddrCommDtls Start\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - addrCommList.size() --->> 0\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - messageRecipients without Adrs Com ID() --->> MessageRecipient [messageType=null, messageVersion=null, messageStandard=null, envelopeType=null, splitterClassName=null, addressType=null, address=null]\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - ----Recipients are----\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient AddressComm ID--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address Type--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Participant ID--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Route Communication ID--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Route Communication Address Type--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Type--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Version--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Message Standard--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Address Envelope Type--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Recipient Splitter Class--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Send Original Message--null\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - -------------------------------------\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.s.i.MessageRouteServiceImpl U:UNKNOWN SC:17740 TX:0 - Method identifyMessageRecipients -- End\n"
+ "2018-11-25 14:27:58.098 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.route.MessageRouteProcessor U:UNKNOWN SC:17740 TX:0 - MessageRouteProcessor process method -- End\n"
+ "2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17740 TX:0 - Starting the processor -com.eix.processor.system.WebServiceProcessor\n"
+ "2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.system.WebServiceProcessor U:UNKNOWN SC:17740 TX:0 - Service Processor is invoking...\n"
+ "2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Invoking webservice http://alteainterface.qatarairways.com.qa/AlteaODS/AlteaODS.svc\n"
+ "2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Response Message : <MESSAGE><HEADER><ServiceName>xxxx xxxx</ServiceName><ServiceType>PassengerInfo</ServiceType><ServiceVersion>1.0</ServiceVersion><Client>xxx</Client><ClientChannel>xx</ClientChannel><MsgChannel>WebServices</MsgChannel><SecurityInfo><Authentication><UserId>xx</UserId><Password>xxx</Password></Authentication></SecurityInfo></HEADER><BODY><RESPONSE><passengerStatus>Invalid</passengerStatus><RegisteredFlight></RegisteredFlight><passengerPhone></passengerPhone><passengerEmail></passengerEmail><FFPNumber></FFPNumber></RESPONSE></BODY></MESSAGE>\n"
+ "2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17740 TX:0 - Starting the processor -com.eix.processor.persistence.OutPersisterProcessor\n"
+ "2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.p.OutPersisterProcessor U:UNKNOWN SC:17740 TX:0 - Out Persister Processor is invoking...\n"
+ "2018-11-25 14:27:58.179 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17740 TX:0 - SesIdCode is null. So no audit log transaction for this transaction\n"
+ "2018-11-25 14:27:58.185 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17633 TX:0 - start updateINAndInsertOutMessageSync\n"
+ "2018-11-25 14:27:58.185 [ajp-bio-172.27.9.196-8009-exec-1] WARN c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Authentication is null\n"
+ "2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Got eix ID from Instance ID 1\n"
+ "2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - ****** Returning EIX ID-> 3\n"
+ "2018-11-25 14:27:58.187 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - Got eix ID from Instance ID 1\n"
+ "2018-11-25 14:27:58.188 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.audit.handler.EixAuditListener U:UNKNOWN SC:17633 TX:0 - ****** Returning EIX ID-> 3\n"
+ "2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17633 TX:0 - SesIdCode is null. So no audit log transaction for this transaction\n"
+ "2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.component.SenderComponent U:UNKNOWN SC:17633 TX:0 - SendMessage, Invockation Start..\n"
+ "2018-11-25 14:27:58.195 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17633 TX:0 - SesIdCode is null. So no audit log transaction for this transaction\n"
+ "2018-11-25 14:27:58.202 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.s.i.MessagePersistenceServiceImpl U:UNKNOWN SC:17618 TX:0 - in updateSendStatusInOutMessage\n"
+ "2018-11-25 14:27:58.202 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.m.d.r.i.OutMessageRepositoryImpl U:UNKNOWN SC:17618 TX:0 - in updateSendStatusInOutMessage\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}