import Foundation
let pattern = #"\[data-testid=([^\]]*?)\](?!.*\[data-testid=.*?\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
@header;.header-area;.sticky;|@div;.container;|@div;.row;|@div;.col-lg-12;|@nav;.navbar;.navbar-expand-lg;|@div;#navbarSupportedContent;.collapse;.navbar-collapse;|@ul;#nav;.ml-auto;.navbar-nav;|@li;.active;.nav-item;|@a;[data-testid=foo];[href=#service];|
@section;#contact;.contact-area;.pt-115;|@div;.container;|@div;.contact-box;.mt-70;|@div;.row;|@div;.col-lg-8;|@div;.contact-form;|@form;#contact-form;[data-toggle=validator];[method=post];|@div;.row;|@div;.col-lg-12;|@div;.form-group;.single-form;|@button;.main-btn;[type=submit][data-testid=bar];|
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)