#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bApplication Name:\s*(.+)(?:\n(?!\s*={3,}\r?$).*)*^\s*Secret Key:\s*(.+)"
Local $sString = "Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW1" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW2" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
" " & @CRLF & _
" Application Name: XYXZW3" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW4" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")