const regex = /(ts.*?)(\s+\+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ts.*?)(\\s+\\+)', 'gm')
const str = `c[ts[0],99:99,99:99] + 5 - d[ts[1],99:99,99:99, ts[2]] + 5`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);