package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:a [ac]+)|(?:b [bd]+))`)
var str = `a caca
b bdbd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}