$re = '/(my-custom:foo|my-custom:bar)/';
$str = '[my-custom:foo]
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);