import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:GET|POST)\\s+([^\\s?]*)";
final String string = "\n\n"
+ " 83.198.250.175 - - [22/Mar/2009:07:40:06 +0100] \"GET /images/ht1.gif HTTP/1.1\" 200 61 \"http://www.facades.fr/\" \"Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Wanadoo 6.7; Orange 8.0)\" \"-\"\n\n"
+ " 65.33.94.190 - - [05/Apr/2003:17:26:27 -0500] \"POST /samples/dem/tt.php?x=e2323 HTTP/1.0\" 404 276\n\n"
+ " 151.227.152.48 - - [02/Jul/2014:14:35:55 +0100] \"GET /css/main.css HTTP/1.1\" 200 4658 \"http://stanmore.menczykowski.co.uk/\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36\"\n\n"
+ " 10.143.2.119 64.103.161.112 - [06/Jan/1970:00:48:01 +0000] \"GET /right_arrow.jpg HTTP/1.1\" 304 0 \"http://64.103.161.112/index_eth_diag.html\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}