#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}-\d{2}-\d{4}), (\d\d:\d\d:\d\d\.\+?\d+)\s*(\+?\d+)\s*(.*\.exe)\s*(.*?)\s*(\+?\d+\.\+?\d+\.\+?\d+.\+?\d+)\s*(\+?\d+)\s*([\w|\d]*)\s*(\d*)\s*(\d*)\s*(.*)"
Local $sString = "//Normal Quintiq Logging" & @CRLF & _
"29-09-2019, 20:50:21.355 15 QServer.exe LP5-BSS7-DSA 10.200.0.64 11784 Main 2 QServerService::RunLoop() Status(SERVICE_STOPPED);" & @CRLF & _
"29-09-2019, 20:50:21.355 1233215 QServer.exe LP5-BSS7-DSA 10.200.0.64 11784 Main 2 QServerService::RunLoop() Status(SERVICE_STOPPED);" & @CRLF & _
"29-09-2019, 21:31:06.424 245 QServer.exe QAG-MXG-CIAG02 10.5.3.144 7132 Trans_3 2 QKBSManager::HandleRequest: 248" & @CRLF & _
"" & @CRLF & _
"//Designer Error" & @CRLF & _
"01-10-2019, 22:23:36.400 5391 QClient.exe QAG-MXG-DCKR5 10.5.3.204 760 Main 8 104493 Path 'Domain:models/hbl%2Fdesignererror/LibSchedulerTM/UI/LibSchedulerTM/Component_FormGanttChartSchedulingCentre_TM/ModeledSecurities_FormGanttChartSchedulingCentre_TM.aus': Reference '/GanttChartSchedulingCentre_TM663/MenuOptimizer' can not be resolved for 'ComponentSecurity'. Please, check whether referenced element exists." & @CRLF & _
"01-10-2019, 22:23:36.405 5392 QClient.exe QAG-MXG-DCKR5 10.5.3.204 760 Main 8 105603 Path 'Domain:models/hbl%2Fdesignererror/LibSchedulerTM/UI/LibSchedulerTM/Component_FormGanttChartSchedulingCentre_TM/ModeledSecurities_FormGanttChartSchedulingCentre_TM.aus': 'ComponentSecurity' can not be properly set to its parent 'ModeledSecurities FormGanttChartSchedulingCentre_TM'."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")