$re = '/\/\*[^;]*;.*?\*\//ms';
$str = '
I\'m new to regex.
I try to remove unused code in project like
/*
// random unmanaged annotation
foo = var;
doSomething();
multilineFunction(a,
b);
*/
and leave "not code" annotation
/*
real annotation
*/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;