using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(= )([0-9])";
string input = @"word = 4
word = 2
word = 8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}