import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*([0]|([-+]?(\\d*\\.)?\\d+)(cm|mm|in|px|pt|pc|Q|em|ex|ch|rem|vw|vh|vmin|vmax|%)){1}([\\t ]+([0]|([-+]?(\\d*\\.)?\\d+)(cm|mm|in|px|pt|pc|Q|em|ex|ch|rem|vw|vh|vmin|vmax|%))){0,3}[\\t ]*$";
final String string = "0\n"
+ " 0 \n"
+ "0px\n"
+ " 0px 0px 0px 0\n"
+ "0 0\n"
+ " 0cm 0px 0ch 0% \n"
+ " 0 0 \n"
+ "0 0 0\n"
+ " 0 0 0 \n"
+ "0 0 0 0\n"
+ "2px 0\n"
+ "+2px\n"
+ "-3px\n"
+ "0 2px\n"
+ " 3cm \n"
+ "0px\n"
+ "0px 0px 0px\n"
+ " 1px \n"
+ " 2px 2px \n"
+ " 3px 3px 3px \n"
+ " 4px 4px 4px 4px \n"
+ "+4px -4px -4px +4px \n"
+ "-1px \n"
+ " -2px -2px \n"
+ " -3px -3px -3px \n"
+ " -4px -4px -4px -4px \n"
+ "1% \n"
+ " 2% 2vh \n"
+ " 3vw 3vh 3% \n"
+ " 4cm 4pt -4vmin 4vmax \n\n"
+ "# Errors - must not match\n"
+ " \n"
+ "00\n"
+ "0 0px 00 \n"
+ "1px-2px \n"
+ " 2px2px \n"
+ " 3pxf 3px 3px sdsd\n"
+ " 4px-4px 4px 4px \n"
+ "4px4px4px4px \n"
+ "4px 4px 4px 4-px \n"
+ "-4px-4px-4px-4px \n"
+ "--3px\n"
+ "+-3px\n"
+ "-4px-4px -4px- 4px \n"
+ "-4\n"
+ "+5\n"
+ "+0px -0\n"
+ "+0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}