re = /(<(?!\/)[^>]+>)\s+(<\/[^>]+>)+|(<(?!\/)[^>]+>)+(<\/[^>]+>)+/mi
str = '<p>
</p>
<a href=""></a>
<img src="">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end