const regex = /.{1,40}(?=[.,!?\s-])|(?<=\n)\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.{1,40}(?=[.,!?\\s-])|(?<=\\n)\\n', 'g')
const str = `Dear reader
this is an example text to show my problem with regex
The dot at the end of the line is not included.
But I want it to be included.
Thanks for your help,
Shibeson.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}