import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S]*?\\[General\\][\\s\\S]*?SystemMustBeRebooted=(\\d)[\\s\\S]*?\\[Install Execution\\][\\s\\S]*?SilentInstall=\"\"(HPUP.exe)\"\".*";
final String string = "[CVA File Information]\n"
+ "CVATimeStamp=20241230T074049\n"
+ "CVASyntaxVersion=2.1A6\n\n"
+ "[Software Title]\n"
+ "US=Realtek HD Audio Driver\n"
+ "AR=Realtek HD Audio Driver\n"
+ "BG=Realtek HD Audio Driver\n"
+ "BR=Realtek HD Audio Driver\n"
+ "CS=Realtek HD Audio Driver\n"
+ "DA=Realtek HD Audio Driver\n"
+ "DE=Realtek HD Audio Driver\n"
+ "EL=Realtek HD Audio Driver\n"
+ "ES=Realtek HD Audio Driver\n"
+ "ET=Realtek HD Audio Driver\n"
+ "FI=Realtek HD Audio Driver\n"
+ "FR=Realtek HD Audio Driver\n"
+ "HE=Realtek HD Audio Driver\n"
+ "HK=Realtek HD Audio Driver\n"
+ "HR=Realtek HD Audio Driver\n"
+ "HU=Realtek HD Audio Driver\n"
+ "IT=Realtek HD Audio Driver\n"
+ "JA=Realtek HD Audio Driver\n"
+ "KO=Realtek HD Audio Driver\n"
+ "LT=Realtek HD Audio Driver\n"
+ "LV=Realtek HD Audio Driver\n"
+ "NL=Realtek HD Audio Driver\n"
+ "NO=Realtek HD Audio Driver\n"
+ "PL=Realtek HD Audio Driver\n"
+ "PT=Realtek HD Audio Driver\n"
+ "RO=Realtek HD Audio Driver\n"
+ "RU=Realtek HD Audio Driver\n"
+ "SK=Realtek HD Audio Driver\n"
+ "SL=Realtek HD Audio Driver\n"
+ "SR=Realtek HD Audio Driver\n"
+ "SV=Realtek HD Audio Driver\n"
+ "TH=Realtek HD Audio Driver\n"
+ "TR=Realtek HD Audio Driver\n"
+ "TW=Realtek HD Audio Driver\n"
+ "ZH=Realtek HD Audio Driver\n\n"
+ "[US.Software Description]\n"
+ "This package contains the driver that enables the Realtek High-Definition (HD) Audio in supported notebook models that are running a supported operating system.\n\n"
+ "[AR.Software Description]\n"
+ "ØªØØªÙˆÙŠ Ù‡Ø°Ù‡ Ø§Ù„ØØ²Ù…Ø© على برنامج التشغيل اللازم لتمكين أجهزة صوت Realtek عالية الوضوØ.\n\n"
+ "[BG.Software Description]\n"
+ "Този пакет включва драйвер за активиране на Realtek аудио хардуера Ñ Ð²Ð¸Ñока разделителна ÑпоÑоб\n"
+ "ноÑÑ‚.\n\n"
+ "[BR.Software Description]\n"
+ "Este pacote inclui o driver que habilita o hardware de áudio de alta definição Realtek.\n\n"
+ "[CS.Software Description]\n"
+ "Toto balenà obsahuje ovladaÄ, který aktivuje zvukový hardware s vysokým rozliÅ¡enÃm.\n\n"
+ "[DA.Software Description]\n"
+ "Denne pakke indeholder driveren, som muliggør Realtek HD-lydhardware.\n\n"
+ "[DE.Software Description]\n"
+ "Dieses Paket enthält den Realtek-HD-Audio-Treiber.\n\n"
+ "[EL.Software Description]\n"
+ "Το πακÎτο αυτό πεÏιÎχει το Ï€ÏόγÏαμμα οδήγησης για την ενεÏγοποίηση του Ï…Î»Î¹ÎºÎ¿Ï Î®Ï‡Î¿Ï… υψηλής ευ\n"
+ "κÏίνειας Realtek.\n\n"
+ "[ES.Software Description]\n"
+ "Este paquete incluye el controlador para habilitar el hardware de audio Realtek de alta definición.\n\n"
+ "[ET.Software Description]\n"
+ "Realtek kõrglahutusega heliriistvara lubamiseks sisaldab see pakett vastavat draiverit.\n\n"
+ "[FI.Software Description]\n"
+ "Tämä pakkaus sisältää ohjaimen, joka mahdollistaa äänilaitteen Realtek-teräväpiirtoäänen.\n\n"
+ "[FR.Software Description]\n"
+ "Cet emballage contient le pilote pour activer le matériel audio haute définition Realtek.\n\n"
+ "[HE.Software Description]\n"
+ "חבילה זו מכילה ×ת ×ž× ×”×œ ההתקן המ×פשר חיבור והפעלה של ×”×ª×§× ×™ שמע Realtek ב×יכות עילית (HD).\n\n"
+ "[HK.Software Description]\n"
+ "本套件包å«ç”¨æ–¼å•Ÿç”¨ Realtek 高傳真音訊硬體的驅動程å¼ã€‚\n\n"
+ "[HR.Software Description]\n"
+ "Ovaj paket sadrži upravljaÄki program koji omogućuje rad Realtek hardvera za zvuk visoke definicije.\n\n"
+ "[HU.Software Description]\n"
+ "Ez a csomag a nagy felbontású élményt nyújtó Realtek hangeszköz működtetéséhez szükséges illesztőprogramot tartalmazza.\n\n"
+ "[IT.Software Description]\n"
+ "Questo pacchetto contiene il driver che consente di attivare l’audio ad alta definizione Realtek.\n\n"
+ "[JA.Software Description]\n"
+ "ã“ã®ãƒ‘ッケージã«ã¯Realtek High-Definition Audioãƒãƒ¼ãƒ‰ã‚¦ã‚§ã‚¢ã‚’有効ã«ã™ã‚‹ãƒ‰ãƒ©ã‚¤ãƒãƒ¼ãŒå«ã¾ã‚Œã¦ã„ã¾ã™ã€‚\n\n"
+ "[KO.Software Description]\n"
+ "본 패키지ì—는 Realtek ê³ í™”ì§ˆ 오디어 하드웨어를 활성화하는 드ë¼ì´ë²„ê°€ 있습니다.\n\n"
+ "[LT.Software Description]\n"
+ "Į šį paketą įeina tvarkyklė, skirta Realtek raiškiojo garso aparatūrai įjungti.\n\n"
+ "[LV.Software Description]\n"
+ "Šī pakotne ietver draiveri, kas iespējo Realtek augstas izšķirtspējas audio aparatūru.\n\n"
+ "[NL.Software Description]\n"
+ "Dit pakket bevat de driver voor het activeren van Realtek high-definition audiohardware.\n\n"
+ "[NO.Software Description]\n"
+ "Denne pakken inkluderer driverer for å aktivere Realtek HD-lydmaskinvare.\n\n"
+ "[PL.Software Description]\n"
+ "Niniejszy pakiet zawiera sterownik urządzenia dźwiękowego Realtek high-definition.\n\n"
+ "[PT.Software Description]\n"
+ "Este pacote inclui o controlador para ativar hardware de áudio Realtek de alta definição.\n\n"
+ "[RO.Software Description]\n"
+ "Acest pachet include driverul pentru activarea echipamentului audio de înaltă definiție (HD) Realtek.\n\n"
+ "[RU.Software Description]\n"
+ "Ðтот пакет Ñодержит драйвер, который обеÑпечивает работу аудио Realtek Ð´Ð»Ñ Ð·Ð²ÑƒÐºÐ¾Ð²Ð¾Ð³Ð¾ оборудоваÐ\n"
+ "½Ð¸Ñ выÑокой чёткоÑти.\n\n"
+ "[SK.Software Description]\n"
+ "Tento balÃk zahŕňa ovládaÄ na aktiváciu zvukového hardvéru Realtek s vysokým rozlÃÅ¡enÃm.\n\n"
+ "[SL.Software Description]\n"
+ "Paket vkljuÄuje gonilnik za omogoÄanje visokoloÄljivostne zvoÄne strojne opreme Realtek.\n\n"
+ "[SR.Software Description]\n"
+ "Ovaj paket obuhvata upravljaÄki program koji će omogućiti Realtek audio hardver visoke definicije.\n\n"
+ "[SV.Software Description]\n"
+ "Detta paket innehåller en drivrutin för aktivering av Realtek High-Definition Audio.\n\n"
+ "[TH.Software Description]\n"
+ "เพà¸à¹€à¸à¸ˆà¸™à¸µà¹‰à¸£à¸§à¸¡à¸–ึงไดรเวà¸à¸£à¹Œà¸—ี่จะเปิดใช้งานฮาร์ดà¹à¸§à¸£à¹Œà¹€à¸ªà¸µà¸¢à¸‡à¸„วามà¸\n"
+ "„มชัด-สูง Realtek\n\n"
+ "[TR.Software Description]\n"
+ "Bu paket, Realtek yüksek tanımlı ses donanımını etkinleştirecek sürücüyü içermektedir.\n\n"
+ "[TW.Software Description]\n"
+ "本套件包å«ç”¨æ–¼å•Ÿç”¨ Realtek 高傳真音訊硬體的驅動程å¼ã€‚\n\n"
+ "[ZH.Software Description]\n"
+ "该包装包å«å¯å¯ç”¨ Realtek 高分辨率音频硬件的驱动程åºã€‚\n\n"
+ "[General]\n"
+ "PN=P01759-B2M\n"
+ "Version=24.9764.1433.30\n"
+ "Revision=Q\n"
+ "Pass=5\n"
+ "Type=Driver\n"
+ "Category=Driver-Audio\n"
+ "SystemMustBeRebooted=0\n"
+ "VendorName=REALTEK\n"
+ "VendorVersion=6.0.9764.1_30Q5\n\n"
+ "[SupportedLanguages]\n"
+ "Languages=GLOBAL\n"
+ "Countries=GBL\n\n"
+ "[ProfessionalInnovations]\n"
+ "HPPI=NO\n"
+ "LearnMore=\n\n"
+ "[DetailFileInformation]\n"
+ "RTKVHD64.sys=<DRIVERS>\\,0x0006,0x0000,0x2624,0x0001,WT64_22H2\n"
+ "RTKVHD64.sys=<DRIVERS>\\,0x0006,0x0000,0x2624,0x0001,W11_22H2\n"
+ "RTKVHD64.sys=<DRIVERS>\\,0x0006,0x0000,0x2624,0x0001,W11_23H2\n"
+ "RTKVHD64.sys=<DRIVERS>\\,0x0006,0x0000,0x2624,0x0001,W11_24H2\n\n"
+ "[Softpaq]\n"
+ "SoftpaqNumber=SP156235\n"
+ "SupersededSoftpaqNumber=SP154247\n"
+ "SoftPaqMD5=12AA316EC1625CAABB8FF56ACD5D1138\n"
+ "SoftPaqSHA256=AB4EBF5DCBEF5885786AE90A5B873B49418A8733366EF53489E806F7EE1C2919\n"
+ "SoftPaqSHA512=99261FFCD00E912D5449A5B2EC41229FB5FB02D69E0DF2D2878911877E98F6F66FB449600F356129B2386545F459A6CD5D5D3634D16D716C35BD1FF42184125B\n\n"
+ "[Devices]\n"
+ "PCI\\VEN_8086&DEV_54C8=\"Intel(R) Smart Sound Technology BUS\"\n"
+ "PCI\\VEN_8086&DEV_51CA=\"Intel(R) Smart Sound Technology BUS\"\n"
+ "PCI\\VEN_8086&DEV_51C8=\"Intel(R) Smart Sound Technology BUS\"\n"
+ "PCI\\VEN_1022&DEV_15E2=\"AMD Audio CoProcessor\"\n"
+ "PCI\\VEN_8086&DEV_7A50=\"Intel(R) Smart Sound Technology BUS\"\n"
+ "PCI\\VEN_8086&DEV_7E28=\"Intel®? Smart Sound Technology BUS\"\n"
+ "PCI\\VEN_8086&DEV_7F50=\"Intel®? Smart Sound Technology BUS\"\n\n"
+ "[Devices_INFPath]\n"
+ "WT64_22H2_INFPath=src\\driver\n"
+ "W11_22H2_INFPath=src\\driver\n"
+ "W11_23H2_INFPath=src\\driver\n"
+ "W11_24H2_INFPath=src\\driver\n\n"
+ "[System Information]\n"
+ "SysId01=0x8CF5\n"
+ "SysName01=HP ZBOOK STUDIO 16 INCH G11 MOBILE\n"
+ "SysId02=0x8C26\n"
+ "SysName02=HP ELITE X360 830 13 INCH G11,HP ELITEBOOK 830 13 INCH G11,HP ELITEBOOK 860 16 INCH G11,HP ELITEBOOK 840 14 INCH G11\n"
+ "SysId03=0x8C85\n"
+ "SysName03=HP ELITEBOOK 630 13.3 INCH G11\n"
+ "SysId04=0x8CA0\n"
+ "SysName04=HP ZBOOK POWER 16 INCH G11 MOBILE\n"
+ "SysId05=0x8C52\n"
+ "SysName05=HP ELITE X360 1040 14 INCH G11,HP ELITEBOOK 1040 14 INCH G11\n"
+ "SysId06=0x8C83\n"
+ "SysName06=HP PROBOOK 440 14 INCH G11\n"
+ "SysId07=0x8C86\n"
+ "SysName07=HP ELITEBOOK 640 14 INCH G11\n"
+ "SysId08=0x8CD1\n"
+ "SysName08=HP ZBOOK FIREFLY 14 INCH G11 MOBILE,HP ZBOOK FIREFLY 16 INCH G11 MOBILE\n"
+ "SysId09=0x8C87\n"
+ "SysName09=HP ELITEBOOK 660 16 INCH G11\n"
+ "SysId10=0x8C84\n"
+ "SysName10=HP PROBOOK 460 16 INCH G11\n\n"
+ "[Operating Systems]\n"
+ "WT64_22H2=OEM\n"
+ "W11_22H2=OEM\n"
+ "W11_23H2=OEM\n"
+ "W11_24H2=OEM\n\n"
+ "[US.Enhancements]\n"
+ "- Increase microphone default values of volume and boost.\n\n"
+ "- Includes the following drivers:\n"
+ "Cirrus Logic Awesome Speaker Amps Driver, version 21.51.46.157\n"
+ "Fortemedia Audio Effects Component Driver, version 12.1.6003.6017\n"
+ "Intel Smart Sound Technology BUS Driver, version 20.40.11433.4\n"
+ "Intel Smart Sound Technology OED Driver, version 20.40.11433.4\n"
+ "Realtek Audio Driver, version 6.0.9764.1\n\n"
+ "[Install Execution]\n"
+ "Install=\"HPUP.exe\"\n"
+ "SilentInstall=\"HPUP.exe\"\n\n"
+ "[ReturnCode]\n"
+ "1024:SUCCESS:REBOOT=A restart is required to complete the install. This message is indicative of a success\n"
+ "400:SUCCESS:REBOOT=A restart is required to complete the install. This message is indicative of a success\n"
+ "0:SUCCESS:NOREBOOT=The action completed successfully\n\n"
+ "[Private]\n"
+ "Private_SSMCompliant=1\n"
+ "HardwareSupportApp_Compliant=0\n"
+ "DPB_Compliant=1\n"
+ "MS_Store_App=0\n"
+ "DriverType=Universal\n"
+ "Private_ReleaseType=Routine\n"
+ "Private_ProductType = Notebooks\n\n"
+ "[Private_Fixes]\n"
+ "- Fixes an issue where noise suppression does not function properly during a VoIP call.\n"
+ "- Fixes an issue where the Fortemedia Audio driver causes memory leaks to occur.\n"
+ "- Fixes an issue where the hotkey mic mute button does not sync with certain Bluetooth headphones.\n\n"
+ "[Private_SoftpaqInstall]\n\n"
+ "1. Download the file by clicking the Download or Obtain Software button and saving the file to a folder on your hard drive (make a note of the folder where the downloaded\n"
+ " file is saved).\n\n"
+ "2. Double-click the downloaded file and follow the on-screen instructions.\n\n"
+ "[CVAToolDocumentStamp]\n"
+ "Generated by Release CVA Tool Version 1.0 using Syntax Version 2.0 A1 on 12/30/2024 7:40:49 AM\n"
+ "Copyright (c) 2024 HP Development Company, L.P.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}