# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(#+[^\\\n]*)"
test_str = "### this is a comment\\na = \\'a string\\'.toupper()\\nprint a\\n\\na_var_name = \" ${an.injection} \"\\nanother_var = \" ${bn.injection} \"\\ndtabse_conn = \" ${cn.injection} \"\\n\\ndef do_something()\\n # this call outputs an xml stream of the current parameter dictionary.\\n paramtertools.print_header(params)\\n\\nfor i in xrange(256): # wow another comment\\n print i**2\\n\\n"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.