$re = '/\d{4}$/m';
$str = 'MVI_2546
MVI_9999
2546_MVI
FILETEST';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);