#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![a-zA-Z0-9])mini(?![a-zA-Z0-9])"
Local $sString = "mini" & @CRLF & _
"mini abc" & @CRLF & _
"mini-abc (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"abc mini" & @CRLF & _
"abc-mini (- could be anything else but [a-zA-Z0-9])" & @CRLF & _
"abc mini abc" & @CRLF & _
"abcminiabc-mini (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"mini-abcminiabc (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"miniabc-mini (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"mini-miniabc (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"abcmin-mini (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"mini-abcmini (- could be anything else but not [a-zA-Z0-9])" & @CRLF & _
"" & @CRLF & _
"miniabc" & @CRLF & _
"abcmini" & @CRLF & _
"abcminiabc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")