const regex = /^(?:\+\d{2})?\d{10}(?:,(?:\+\d{2})?\d{10})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+\\d{2})?\\d{10}(?:,(?:\\+\\d{2})?\\d{10})*$', 'gm')
const str = `+919845098450,9845098450,+918976542345
9345678765`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}