re = /<img\s[^>]*src="(?<imageURL>[^"]*)"\s*\/> # IMG tag
.*? # Anything in-between IMG and A
<a\s[^>]*?href="\/title\/tt
(?<imdbid>\d{7}) # Got the imdbid
\/[^>]*>(?<title>.*?) # Got title
<\/a> # End of A tag
\s*\(
(?<year>\d{4}) # Year
\)\s*(?:\( # Type is optional
(?<type>[^<]*) # Type
\))? # End of optional group/ix
str = '<tr class="findResult odd">
<td class="primary_photo"><a href="/title/tt0499549/?ref_=fn_tt_tt_1" ><img src="http://ia.media-imdb.com/images/M/MV5BMTYwOTEwNjAzMl5BMl5BanBnXkFtZTcwODc5MTUwMw@@._V1_SX32_CR0,0,32,44_AL_.jpg" /></a></td>
<td class="result_text"><a href="/title/tt0499549/?ref_=fn_tt_tt_1" >Avatar</a> (2009) </td>
</tr>
<tr class="findResult even">
<td class="primary_photo"><a href="/title/tt0417299/?ref_=fn_tt_tt_2" ><img src="http://ia.media-imdb.com/images/M/MV5BMTM3MTc3OTc0NF5BMl5BanBnXkFtZTcwOTQ0OTM1MQ@@._V1._CR34,0,295,440_SX32_CR0,0,32,44_AL_.jpg" /></a></td>
<td class="result_text"><a href="/title/tt0417299/?ref_=fn_tt_tt_2" >Avatar: The Last Airbender</a> (2005) (TV Series) </td>
</tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end