package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Brand(.*?)®`)
var str = `BrandTest® BrandBottle® BrandJuice®`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}