package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,{]*(?:\{[^{}]*\})*[^,}]*`)
var str = `{q0,q1,q2,q3},{a,b},q0,{q1,q3}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}