# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<text[^>]+>?.+?([а-яА-Я]+)"
test_str = ("<g id=\"L-14-st-230\" display=\"inline\" opacity=\"1\">\n"
" <text transform=\"matrix(1 0 0 1 226.6597 827.2749)\" enable-background=\"new \"><tspan x=\"0\" y=\"0\" fill=\"#191919\" font-family=\"'PTSans-Regular'\" font-size=\"16\">Деловой центр</tspan><tspan x=\"31.6\" y=\"14\" fill=\"#191919\" font-family=\"'PTSans-Regular'\" font-size=\"16\">(МЦК)</tspan></text>\n"
" </g>\n\n"
"<g id=\"L-14-st-228\" display=\"inline\" opacity=\"1\">\n"
" <text transform=\"matrix(1 0 0 1 444.9458 1066.8765)\" fill=\"#191919\" font-family=\"'PTSans-Regular'\" font-size=\"16\">Лужники</text>\n"
" </g>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.