$re = '/(\d{2,100})\1/';
$str = '22222
1111
2323
1
11
1212
14
14
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);