package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`".*?"(*SKIP)(*FAIL)|\s+`)
var str = `Hello World "Hello World"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}